const regex = /(?i)\b([QI]{2}|[Q])[\\s || -]{0,2}[0-9]{5,}[\\s || -]{0,2}\K[A-Z]{3}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\b([QI]{2}|[Q])[\\\\s || -]{0,2}[0-9]{5,}[\\\\s || -]{0,2}\\K[A-Z]{3}\\b', 'gm')
const str = `The quote number is Q-123123-PAD with many QI123123 PAD AB01231231PAD
Q-12311-APD
the the the the the`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}