re = /(?i)\b([QI]{2}|[Q])[\\s || -]{0,2}[0-9]{5,}[\\s || -]{0,2}\K[A-Z]{3}\b/m
str = 'The quote number is Q-123123-PAD with many QI123123 PAD AB01231231PAD
Q-12311-APD
the the the the the'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end