const regex = /^[1-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]$', 'gm')
const str = `0
1
2
3
4
5
6
7
8
9
10
11
12
20
30
45
56
67
89
78
88
90
99
100
101
1010
10102`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}