$re = '/^[1-9]$/m';
$str = '0
1
2
3
4
5
6
7
8
9
10
11
12
20
30
45
56
67
89
78
88
90
99
100
101
1010
10102';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);