// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]$").unwrap();
let string = "0
1
2
3
4
5
6
7
8
9
10
11
12
20
30
45
56
67
89
78
88
90
99
100
101
1010
10102";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}