#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(?:thrive|boost)(?:\/)?(?:.*[^0-9a-zA-Z].*)?(?:\\.aspx)?"
Local $sString = "http://apples.com/thrive/" & @CRLF & _
"" & @CRLF & _
"http://apples.com/thrive" & @CRLF & _
"" & @CRLF & _
"http://apples.com/thrive/asdhjf/asdjfka/asdjok/asdjfp" & @CRLF & _
"" & @CRLF & _
"http://apples.com/thrive/asdhjf/asdjfka/asdjok/asdjfp.aspx" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://apples.com/boost/" & @CRLF & _
"" & @CRLF & _
"http://apples.com/boost" & @CRLF & _
"" & @CRLF & _
"http://apples.com/boost/asdhjf/asdjfka/asdjok/asdjfp" & @CRLF & _
"" & @CRLF & _
"http://apples.com/boost/asdhjf/asdjfka/asdjok/asdjfp.aspx" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")