re = /\/(?:thrive|boost)(?:\/)?(?:.*[^0-9a-zA-Z].*)?(?:\\.aspx)?/m
str = 'http://apples.com/thrive/
http://apples.com/thrive
http://apples.com/thrive/asdhjf/asdjfka/asdjok/asdjfp
http://apples.com/thrive/asdhjf/asdjfka/asdjok/asdjfp.aspx
http://apples.com/boost/
http://apples.com/boost
http://apples.com/boost/asdhjf/asdjfka/asdjok/asdjfp
http://apples.com/boost/asdhjf/asdjfka/asdjok/asdjfp.aspx
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end