$re = '/\/(?:thrive|boost)(?:\/)?(?:.*[^0-9a-zA-Z].*)?(?:\\\\.aspx)?/m';
$str = 'http://apples.com/thrive/
http://apples.com/thrive
http://apples.com/thrive/asdhjf/asdjfka/asdjok/asdjfp
http://apples.com/thrive/asdhjf/asdjfka/asdjok/asdjfp.aspx
http://apples.com/boost/
http://apples.com/boost
http://apples.com/boost/asdhjf/asdjfka/asdjok/asdjfp
http://apples.com/boost/asdhjf/asdjfka/asdjok/asdjfp.aspx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);