import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@\\w+)";
final String string = "@word1 <p>ipsum dolor sit @word2 amet, consectetur adipiscing elit. Ut facilisis accumsan augue, <span>@word3</span>@word4 eget laoreet elit efficitur ut. sample@domain.com Fusce nulla ante, aliquam vel est sed, fringilla auctor risus. Ut consectetur mi non felis tincidunt, sit amet tincidunt massa placerat.</p>@word5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}