re = /(@\w+)/
str = '@word1 <p>ipsum dolor sit @word2 amet, consectetur adipiscing elit. Ut facilisis accumsan augue, <span>@word3</span>@word4 eget laoreet elit efficitur ut. sample@domain.com Fusce nulla ante, aliquam vel est sed, fringilla auctor risus. Ut consectetur mi non felis tincidunt, sit amet tincidunt massa placerat.</p>@word5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end