$re = '/(?:\([^()]*\)|\[[^\]\[]*]|[^|])+/m';
$str = '(name|address)|blah
([name|address])
[name|address]
(hello|all)
|Hello all, | morning [name|address] |';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);