// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\([^()]*\)|\[[^\]\[]*]|[^|])+").unwrap();
let string = "(name|address)|blah
([name|address])
[name|address]
(hello|all)
|Hello all, | morning [name|address] |";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}