re = /(?:\([^()]*\)|\[[^\]\[]*]|[^|])+/m
str = '(name|address)|blah
([name|address])
[name|address]
(hello|all)
|Hello all, | morning [name|address] |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end