package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`INSERT INTO (\S+) \((\S+)\) VALUES \((\S+)\) , \((\S+)\)`)
var str = `INSERT INTO table_name (c1,c2,c3) VALUES (abc,def,ghi) , (jkl,mno,pqr)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}