$re = '/INSERT INTO (\S+) \((\S+)\) VALUES \((\S+)\) , \((\S+)\)/';
$str = 'INSERT INTO table_name (c1,c2,c3) VALUES (abc,def,ghi) , (jkl,mno,pqr)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);