const regex = /INSERT INTO (\S+) \((\S+)\) VALUES \((\S+)\) , \((\S+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('INSERT INTO (\\S+) \\((\\S+)\\) VALUES \\((\\S+)\\) , \\((\\S+)\\)', 'g')
const str = `INSERT INTO table_name (c1,c2,c3) VALUES (abc,def,ghi) , (jkl,mno,pqr)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}