#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-CC\s*(.*?)\s+-"
Local $sString = "20181223-FB-BOOST-AAAA-CC Auchy-Les-Mines - Père Noel" & @CRLF & _
"20161224-FB-BOOST-SSSS-CC LeMarine - XXX XXX" & @CRLF & _
"20161223-FB-BOOST-XXXX-CC Bonjour le monde - Blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")