re = /-CC\s*(.*?)\s+-/m
str = '20181223-FB-BOOST-AAAA-CC Auchy-Les-Mines - Père Noel
20161224-FB-BOOST-SSSS-CC LeMarine - XXX XXX
20161223-FB-BOOST-XXXX-CC Bonjour le monde - Blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end