import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-CC\\s*(.*?)\\s+-";
final String string = "20181223-FB-BOOST-AAAA-CC Auchy-Les-Mines - Père Noel\n"
+ "20161224-FB-BOOST-SSSS-CC LeMarine - XXX XXX\n"
+ "20161223-FB-BOOST-XXXX-CC Bonjour le monde - Blah blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}