$re = '/^[Oo]rgani.e$|^[Oo]rgani.e\w$/m';
$str = 'organise
Organi1e
Organizer
organifed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);