re = /^[Oo]rgani.e$|^[Oo]rgani.e\w$/m
str = 'organise
Organi1e
Organizer
organifed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end