import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[A-Z)])(\\d+)";
final String string = "H2O должно стать - H<sub>2</sub>O\n"
+ "(NH4)2SO4 должно стать - (NH<sub>4</sub>)<sub>2</sub>SO<sub>4</sub>";
final String subst = "<sub>$1</sub>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}