$re = '/(?<=[A-Z)])(\d+)/m';
$str = 'H2O должно стать - H<sub>2</sub>O
(NH4)2SO4 должно стать - (NH<sub>4</sub>)<sub>2</sub>SO<sub>4</sub>';
$subst = "<sub>$1</sub>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;