use strict;
my $str = 'H2O должно стать - H<sub>2</sub>O
(NH4)2SO4 должно стать - (NH<sub>4</sub>)<sub>2</sub>SO<sub>4</sub>';
my $regex = qr/(?<=[A-Z)])(\d+)/mp;
my $subst = '<sub>$1</sub>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";