#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?: *- *\d+)?(?:, *\d+(?: *- *\d+)?)*$"
Local $sString = "1,3,5-7, 10, 15 - 20" & @CRLF & _
"1" & @CRLF & _
"1,2" & @CRLF & _
"15, 16-17" & @CRLF & _
"3-4" & @CRLF & _
"6-8" & @CRLF & _
"6 - 9" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")