$re = '/^\d+(?: *- *\d+)?(?:, *\d+(?: *- *\d+)?)*$/m';
$str = '1,3,5-7, 10, 15 - 20
1
1,2
15, 16-17
3-4
6-8
6 - 9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);