package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?: *- *\d+)?(?:, *\d+(?: *- *\d+)?)*$`)
var str = `1,3,5-7, 10, 15 - 20
1
1,2
15, 16-17
3-4
6-8
6 - 9
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}