import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^*\\n]*\\*){2}([^*\\n]*)";
final String string = "LLC1R.8888.GR0054656*DR.798012...2..............GR0054656*CNY*ARTIST*\n"
+ "TC1R.88.GR0054656*DR.765012...2..............GR0054656*EUR*LUKE*\n"
+ "K56R.8.GR0054656*DR.258812...4..............GR0054656*AUD*\n"
+ "790GG.88.GR0054656*DR.338012...5..............GR0054656*IDR*MATTHEW*\n"
+ "GREFD.888.GR0054656*DR.198012...6..............GR0054656*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}