using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"string1:(\d+).*?string3:(.*?)(?=string|$)";
string input = @"string1:1234string2string3:a1b2c3string1:2345string3:b5c6d7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}