re = /string1:(\d+).*?string3:(.*?)(?=string|$)/m
str = 'string1:1234string2string3:a1b2c3string1:2345string3:b5c6d7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end