import re
regex = re.compile(r"string1:(\d+).*?string3:(.*?)(?=string|$)", flags=re.MULTILINE)
test_str = "string1:1234string2string3:a1b2c3string1:2345string3:b5c6d7"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")