#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)identifier\(\$(\w+)\)|\$(\w+)"
Local $sString = "FUNC($VAR);" & @CRLF & _
"IDENTIFIER($VAR_NAME)" & @CRLF & _
"identifier($VAR_NAME)" & @CRLF & _
"SELECT * FROM $VAR_NAME" & @CRLF & _
"DATEADD('DAY',+1,$VAR_NAME)"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)