package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)identifier\(\$(\w+)\)|\$(\w+)`)
var str = `FUNC($VAR);
IDENTIFIER($VAR_NAME)
identifier($VAR_NAME)
SELECT * FROM $VAR_NAME
DATEADD('DAY',+1,$VAR_NAME)`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}