use strict;
my $str = 'FUNC($VAR);
IDENTIFIER($VAR_NAME)
identifier($VAR_NAME)
SELECT * FROM $VAR_NAME
DATEADD(\'DAY\',+1,$VAR_NAME)';
my $regex = qr/identifier\(\$(\w+)\)|\$(\w+)/mip;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";