import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\/]+(?=\\.\\w+$)\\.\\w+$";
final String string = "https://cdn.nlark.com/yuque/0/2024/png/184438/1725935789441-7fcfe714-3a05-40d8-90b5-62a21ea95695.png\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}