re = /[^\/]+(?=\.\w+$)\.\w+$/m
str = 'https://cdn.nlark.com/yuque/0/2024/png/184438/1725935789441-7fcfe714-3a05-40d8-90b5-62a21ea95695.png
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end