using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@hello#(?!\d)";
string input = @"How can I match a word like @hello# without catching the word @hello#1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}