re = /@hello#(?!\d)/m
str = 'How can I match a word like @hello# without catching the word @hello#1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end