$re = '/@hello#(?!\d)/m';
$str = 'How can I match a word like @hello# without catching the word @hello#1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);