package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[Cats:.*?\]\]`)
var str = `[[Cats: Text1]] said I am in the [[Cats: Text2]]fhg is abnorn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}