$re = '/\[\[Cats:.*?\]\]/m';
$str = '[[Cats: Text1]] said I am in the [[Cats: Text2]]fhg is abnorn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);