re = /\[\[Cats:.*?\]\]/m
str = '[[Cats: Text1]] said I am in the [[Cats: Text2]]fhg is abnorn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end