package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([a-zA-Z][\w\d-]+)`)
var str = `black PENS Assorted Bit Set 10Pcs
Hollow blocks 10-16mm Cd3
Hollow blocks 16-23mm Cd3
Hollow blocks 5-10mm Cd3
Hollow blocks To 1-5mm Cd3-333 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}