import re
regex = re.compile(r"\b([a-zA-Z][\w\d-]+)", flags=re.MULTILINE)
test_str = ("black PENS Assorted Bit Set 10Pcs \n"
"Hollow blocks 10-16mm Cd3 \n"
"Hollow blocks 16-23mm Cd3 \n"
"Hollow blocks 5-10mm Cd3 \n"
"Hollow blocks To 1-5mm Cd3-333 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")