#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?|(OK: ALL OK) (?:\(.*\))|(ERROR: .*))"
Local $sString = "OK: ALL OK (8536972.66889)" & @CRLF & _
"ERROR: ioerror/8536615.22927" & @CRLF & _
"OK: ALL OK (8546369.92291)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")