re = /(?|(OK: ALL OK) (?:\(.*\))|(ERROR: .*))/m
str = 'OK: ALL OK (8536972.66889)
ERROR: ioerror/8536615.22927
OK: ALL OK (8546369.92291)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end