package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(OK: ALL OK) (?:\(.*\))|(ERROR: .*))`)
var str = `OK: ALL OK (8536972.66889)
ERROR: ioerror/8536615.22927
OK: ALL OK (8546369.92291)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}