package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)7PTC[\w\d]{4}`)
var str = `7PTC69RT 7PTC67KM 7PTC689F`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}