$re = '/7PTC[\w\d]{4}/m';
$str = '7PTC69RT 7PTC67KM 7PTC689F';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);