using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ssh\s\|\s(?<FIELD_NAME>\S+)";
string input = @"event 1:
31.138.204.1 | ssh | o*1N0HIQQx434x12481145x1 | ZI53713 | 2018-05-28 07:14:47,848 | SSH - piv-receive-pack '/hvq849/spcp-mdo-scoring.git' | - | 0 | 15122 | 738 | push, ssh:user:id:121237 | 1595 | 10togc8 |
event 2:
31.138.204.1 | ssh | i*1N0HIQQx434x12481145x1 | ZI53713 | 2018-05-28 07:14:47,848 | SSH - piv-receive-pack '/hvq849/spcp-mdo-scoring.git' | - | 0 | 15122 | 738 | push, ssh:user:id:121237 | 1595 | 10togc8 |
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}